MP4 player will only see AVIs (not AMV) and won't play

Video encoding, MTV, DMV, AMV, AMR, fps and everything video-related

Moderator: scrub50187

MP4 player will only see AVIs (not AMV) and won't play

Postby calforba » Fri Feb 02, 2007 2:05 pm

Image

This is driving me nuts.

I bought this MP4 player before Christmas and have yet to been able to play any video except the demo video which was preloaded (8 minutes of Ice Age)

This is what the manufacturers (http://btb.en.alibaba.com/product/50328214/51478822/MP3_MP4/Digital_MP4_player.html) claim:

1:2 inches 260,000 colors real colors TFT colored tablet demonstration.
2:Supports MP3, WMA,WAV (only in this machine recording document) the music form,the
real audio frequency frequency spectrum demonstrated, A-B duplicate reads the
function.
3:Supports MPEG-4 (AVI) the video frequency form, entire screen broadcast demonstration,outside
sound speaker broadcast.
4:Support transformation video frequency form:AVI RM RMVB MPG MPEG MP4 ASF WMV MKV DAT VOB and so on..

The player was accompanied by drivers and software including AMV Converter (3.5.02 and 4.07).

Now here's the problem:

The player does not see any type of video files except AVI files. AMV Files when browsed for, are unplayable. So I'm not sure why the AMV converter is included.

OK but I still can't play any AVI files EXCEPT Ice Age.

I have taken the Ice Age AVI and analysed it. This is the mediainfo analysis:

Format : AVI
Format/Info : Audio Video Interleave
Format/Family : RIFF
File size : 35.1 MiB
PlayTime : 8mn 8s
Bit rate : 595 Kbps
StreamSize : 898 KiB
Writing application : MEncoder Sherpya-MinGW-20060312-4.1.0
Writing library : MPlayer

Video #0
Codec : XviD
Codec/Family : MPEG-4
Codec/Info : XviD project
Codec settings/BVOP : No
Codec settings/QPel : No
Codec settings/GMC : 0
Codec settings/Matri : Default
PlayTime : 8mn 8s
Bit rate : 494 Kbps
Width : 224 pixels
Height : 176 pixels
Aspect ratio : 4/3
Frame rate : 20.000 fps
Resolution : 8 bits
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.616
StreamSize : 28.7 MiB
Writing library : XviD0041

Audio #0
Codec : MPEG-1 Audio layer 2
PlayTime : 8mn 8s
Bit rate : 94 Kbps
Bit rate mode : CBR
Channel(s) : 2 channels
Sampling rate : 44 KHz
Resolution : 16 bits
StreamSize : 5.45 MiB

I've then converted files to as close to this criteria as River Past Cleaner can get (for example):

Format : AVI
Format/Info : Audio Video Interleave
Format/Family : RIFF
File size : 2.11 MiB
PlayTime : 1mn 150ms
Bit rate : 287 Kbps
StreamSize : 115 KiB

Video #0
Codec : XviD
Codec/Family : MPEG-4
Codec/Info : XviD project
Codec settings/BVOP : No
Codec settings/QPel : No
Codec settings/GMC : 0
Codec settings/Matri : Default
PlayTime : 1mn 150ms
Bit rate : 183 Kbps
Width : 224 pixels
Height : 176 pixels
Aspect ratio : 4/3
Frame rate : 20.000 fps
Resolution : 8 bits
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.226
StreamSize : 1.31 MiB
Writing library : XviD0046

Audio #0
Codec : MPEG-1 Audio layer 3
Codec profile : Joint stereo
PlayTime : 1mn 48ms
Bit rate : 96 Kbps
Bit rate mode : CBR
Channel(s) : 2 channels
Sampling rate : 32 KHz
Resolution : 16 bits
Video0 delay : 36ms
StreamSize : 703 KiB

I realise there are small differences but I have done hundreds of different versions and have altered each one.

Still Nothing.

Ice Age.AVI will play - and nothing else.

Has anybody got any ideas?

Cheers!
calforba
 
Posts: 2
Joined: Fri Feb 02, 2007 1:43 pm

Solved!

Postby calforba » Fri Feb 02, 2007 3:39 pm

The problem was this is a RockChip MP4 player and they included the wrong software (and description on the site.

The solution Tutorial is here

http://uploaded.to/?id=489df9


The program is here

http://www.xilisoft.com/mp4-converter.html


Thread here

http://www.mympxplayer.org/avi-files-on-rockchip-player-20-tft-vt1619.html


Alternative direct converter here (AV CONVERTER)

http://www.uxcell.com/public/mp4/mp038_avconverter.zip

Cheers
Cal
calforba
 
Posts: 2
Joined: Fri Feb 02, 2007 1:43 pm

Postby redrosebeauty90 » Sat Feb 03, 2007 7:16 pm

calforba - thanks for the info. Hopefully this'll be able to convert videos to the format supported by my rockchip player
User avatar
redrosebeauty90
Beginner
 
Posts: 36
Joined: Tue Aug 15, 2006 4:02 pm
Location: For me to know and you not to find out. (Just kidding, USA)

Postby forkart » Sat Mar 03, 2007 4:55 pm

I use yasa mp4 video converter to convert video file to mp4 .
http://www.yasasoft.com/mp4videoconverter/
forkart
 
Posts: 1
Joined: Sat Mar 03, 2007 4:53 pm

Postby HoOLi » Sat Jul 14, 2007 3:51 am

I'm a linux user with a similar model and after many attempts, I successfully used :

mencoder input.mp4 -ofps 24 -vf-add scale=224:176 -vf-add expand=224:176:-1:-1:1 -srate 44100 -ovc xvid -xvidencopts bitrate=550:max_bframes=0:quant_type=h263:me_quality=4 -oac lavc -lavcopts acodec=mp2:abitrate=128 -o output.avi

(I'm posting this for my record if anything - I spent so much freakin' time looking at 'Warning: File Format incorrect!')

:P
Last edited by HoOLi on Sun Jul 15, 2007 2:21 am, edited 1 time in total.
HoOLi
 
Posts: 1
Joined: Sat Jul 14, 2007 3:45 am

Postby Zim_256 » Sat Jul 14, 2007 7:12 pm

You are encoding your video with MPEG 1 layer 3 audio @32.000 kHz, you should encode with MPEG 1 Layer 2 @44.100 kHz
Z6 Comp Sys
User avatar
Zim_256
s1 mp3 poster
s1 mp3 poster
 
Posts: 249
Joined: Thu May 25, 2006 5:47 pm
Location: Argentina


Return to Video related (MTV, AMV, encoders, etc.)

Who is online

Users browsing this forum: No registered users and 2 guests



cron