Instructions on how to update your firmware to 3.5.37

Post about the firmware you have and the fatures they got. Please, don't ask for firmware files!

Instructions on how to update your firmware to 3.5.37

Postby loverboy1981 » Thu Aug 31, 2006 11:50 pm

Hello.

Warning! Please consider, that you can damage your player, if you do, what i have written down here. If you do not know, what you are doing, stop here and leave your player as it is. I'm not responsible for damaged players.

I compared the md5-hashes of all included files from up to twenty different firmware files. Now, i think to know, which files all players have common, which files are different from version to version and the most important thing which files are different in each player. So i think, that i found a way how almost everyone can update his nano-like mp4-player, so that it has file browsing feature and full ogg support.

This firmware trick should only work on nano like mp4 players like this:

Image

First make a dump of your original firmware.

For doing this, just download http://www.stud.uni-karlsruhe.de/~uwa8/s1mp3/download/s1fwx_v30.zip, extract the files to a folder of your choice, connect your player, run extract.bat from the folder and type in the letter of the players disc drive. The programm now saves a copy of the players firmware into the folder named dump.bin.

Now download EasyFW 3.7 from http://forum.easydigi.com/viewFile.asp?BoardID=88&ID=2236.

Extract all files and run EasyFW 3.7

Click on "Load Firmware" and load your dumped firmware file into the programm.

EasyFW will now create an "ACT" folder on your computer. You normally can find this folder under

C:\Documents and Settings\User\Local Settings\Temp

Rename the "ACT" folder to "ORIG" using windows explorer

Go back to EasyFW and note your battery type and if you have a radio on your player. Then close EasyFW.

Download my general 3.5.37 firmware here

Open EasyFW again

Load my firmware into EasyFW

Now go to C:\Documents and Settings\User\Local Settings\Temp\ORIG using windows explorer

copy the files

C:\Documents and Settings\User\Local Settings\Temp\ORIG\BRECF641.BIN
C:\Documents and Settings\User\Local Settings\Temp\ORIG\SYSINFO.BIN

to C:\Documents and Settings\User\Local Settings\Temp\ACT\ and overwrite the old files

Now copy the files

C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\SD_FF321.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\SD_FF641.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\SD_FF644.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_FF321.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_FF641.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_FF644.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_SDMMC.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_SF321.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_SF641.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UD_SF644.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UI_6B33L.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UI_6B33S.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\UI_6B33T.DRV
C:\Documents and Settings\User\Local Settings\Temp\ORIG\FW\SYSINFO.BIN

to to C:\Documents and Settings\User\Local Settings\Temp\ACT\FW\ and overwrite the old files

If you want to, you can overwrite the files LOGO.RES and END.RES with your version too. These are the starting and Closing Animations of the Player. But you needn't change, if you like the animations in my firmware.

Now go back to EasyFW, change the settings of battery and radio depending on your original firmware settings, click on create firmware, type in a name, save the new firmware, upload it to your player and tell me your results.
Last edited by loverboy1981 on Mon Sep 04, 2006 7:32 pm, edited 5 times in total.
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby loverboy1981 » Thu Aug 31, 2006 11:51 pm

If you hadn't BRECF641.BIN on your computer, you have another player and i don't know, if changing the firmware in my way works. But there could be a way.

Make all steps except copying files

C:\Documents and Settings\User\Local Settings\Temp\ORIG\BRECF641.BIN
C:\Documents and Settings\User\Local Settings\Temp\ORIG\SYSINFO.BIN

and instead of going back to EasyFW, you rename the new ACT folder to CHANGED or something else.

Now close EasyFW without saving. Open EasyFW again, load your original dump.bin into EasyFW. Check where the files FWSCFxxx.BIN and ADFUFxxx.AP are.

Tf they are under C:\Documents and Settings\User\Local Settings\Temp\ACT\ leave it there and delete all files in FW folder
Tf they are under C:\Documents and Settings\User\Local Settings\Temp\ACT\FW\ delete all files in FW folder except that two files

Now copy all files from C:\Documents and Settings\User\Local Settings\Temp\CHANGED\FW\ to C:\Documents and Settings\User\Local Settings\Temp\ACT\FW\

Now go to EasyFW and delete all files under FWIMAGE.FW but not FWIMAGE.FW itself using the button "Del file"

Now insert all files from C:\Documents and Settings\User\Local Settings\Temp\ACT\FW\ to EasyFW using the button "Add File" so that you can find the files under FWIMAGE.FW.

If you added all the files, change the settings of battery and radio depending on your original firmware settings, click on create firmware, type in a name, save the new firmware, upload it to your player and tell me your results.
Last edited by loverboy1981 on Tue Sep 05, 2006 9:21 pm, edited 1 time in total.
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby loverboy1981 » Fri Sep 01, 2006 12:13 am

If it works on your player, it would be nice, if you could donate some money using paypal to kaminski2006"at"arcor.de (@ instead of "at").

Unfortunately, one of my three players is gone to hell during testing of changing every single file and i want to get a new one.

I'm working on an 80's style theme together with a professional designer. So every donater will get that theme exclusively.

Here's a picture for your first impression. The Animations are missing, but the top and the bottom are almost finished. We want to change the used font into a more discolike and after testing on my player we will tune the colors for bestlooking on our screens.

Image
Last edited by loverboy1981 on Fri Sep 01, 2006 7:52 pm, edited 1 time in total.
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby zwiebug » Fri Sep 01, 2006 7:47 am

great project! but i doubt that your theme will remain closed source for donators only, as there are many ways to spread a file over the internet :) so why not give the theme away for free? btw: i have that exact player like in the picture and it came with the .37 firmware so i won't test your method but it sounds like it could be a good solution for everyone!
zwiebug
 
Posts: 12
Joined: Mon Aug 28, 2006 7:37 pm

Postby loverboy1981 » Fri Sep 01, 2006 1:45 pm

The theme should not be for everybody. We make it for a music project, who wants to sell modded players on their fansite. So, all buyers of the modded players will have the theme.

If anyone will publish the theme here, i couldn't do anything against that. But i will not publish the theme. That's why only donaters will get them from me.

But I think, there won't be more than a few donaters. Most users will upgrade their players even without saying "thanks". But that's how the world is...
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby dotdotdotz » Fri Sep 01, 2006 6:45 pm

tried. seems to be semi-working... only music and fm works, AMV crashes on play, pic viewer doesnt work, text is cut in the exact same way as this post

http://forum.s1mp3.org/viewtopic.php?p=16958
dotdotdotz
s3 poster
 
Posts: 75
Joined: Sat Jun 10, 2006 8:00 pm

Postby mbc » Fri Sep 01, 2006 7:15 pm

It works !!!!
AMV don't crash, picviewer works, filebrowsing is cool.

BUT:

I have lost game, text and telbook from menu.... and I know why:
When I load my firmware with EasyFW or S1Mod, the combobox with FM is empty, nothing is selected. If I select yes(or no), then game,text,telbook are not working, no menu items. (my old firmware 3.5.35)

Now, when I try your method and use your firmware (with radio set to NO), I can't 'unselect' FM and that's the problem.

Can you please post your firmware again, but with no FM selected (if it's unselected after dump)
I-Pod Nano Clone 1.5"
Easytech MN793 2GB Black
Upgraded to 3.5.37
File browsing & OGG
User avatar
mbc
 
Posts: 3
Joined: Sat Aug 26, 2006 9:03 pm
Location: Slovakia

Postby loverboy1981 » Fri Sep 01, 2006 7:21 pm

@dotdotdotz: Interesting. My player hasn't fm radio. That's the only difference, i instantly see.

I do not use video functions but was just testing amv and it works perfectly. Only a small stripe on the left and the right was missing. But it could be, that this was because of the width of the original movie. I have to test my original firmware with this movie to say more.

The picture viewer works even better than the one in my originally firmware. I just tried bmp, jpg, gif and animated gif. All files works perfect.

I thought, i had solved the textcutting problem. One of the post from the thread is from me. That's why i compared every filehash from a full working 3.5.37 and my firmware and solved this problem for my player. The problem was gone on my player, when i used my original UI6B33L,S,T.DRV

Please send me your original firmware file to kaminski2006"at"arcor.de and tell me more details about your player.

The only way to find out the reason of uncorrect fonts is to compare players, where this firmware works with players, where the firmware doesn't work.
Last edited by loverboy1981 on Fri Sep 01, 2006 7:58 pm, edited 1 time in total.
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby mbc » Fri Sep 01, 2006 7:32 pm

DONE !

I enabled game,text and telbook and it works !!!
I used your method with TEMP dir. I loaded my old 3.5.35
firmware with FM unselected.
Then I overwrote the ACT folder with my new dump 3.5.37 folder,
and created a new 3.5.37 firmware with FM leaving unselected.
Everything is working, great.

Thanks.
I-Pod Nano Clone 1.5"
Easytech MN793 2GB Black
Upgraded to 3.5.37
File browsing & OGG
User avatar
mbc
 
Posts: 3
Joined: Sat Aug 26, 2006 9:03 pm
Location: Slovakia

Postby zwiebug » Fri Sep 01, 2006 7:44 pm

so movies don't work correctly? movies is an important factor on this devices, even when watching it on such a small display
zwiebug
 
Posts: 12
Joined: Mon Aug 28, 2006 7:37 pm

Postby loverboy1981 » Fri Sep 01, 2006 7:45 pm

for everyone, who don't know, how to enable game, text and telbook, try waterlily. You can find it somewhere in this forum.

waterlily should work for every firmware created in my way. There you can enable, what you want. I do not need radio, games, textviewing or telebooks. But i tried to enable all features. All except the radio works. The radio could not work because i do not have the chip on my board.
Last edited by loverboy1981 on Fri Sep 01, 2006 8:01 pm, edited 1 time in total.
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby loverboy1981 » Fri Sep 01, 2006 7:50 pm

@mbc: I'm glad that it works for you too. But for helping the other users, please send me the dump of your original firmware and tell us some details about your player. And please think about donating. My player went dead during testing this way file by file.

On my player there are two small errors. The first is, that the firmware-version is not displayed at "firmware info" in settings menu.

the other error is a small graphic bug during playing music. The moving title infos overwrite the logo of the filetyp on the left half of the logo.

Are these bugs on your player too?
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Postby mbc » Fri Sep 01, 2006 8:10 pm

I don't have these bugs.

This is my player:
http://eshop.easytechmp3.com/product_info.php?cPath=21_41&products_id=117&osCsid=71dccfd9b1191c6900e6e0dc4e0f6288

My old firmware info:
MP3 PLAYER
SC85051E
2006/04/07
ACI_V3.5.35

I don't know the chip or memory type, i don't dissassembled it because of warranty.

here is my firmware (old original .35 and the new .37)

http://rapidshare.de/files/31608091/dump.rar
I-Pod Nano Clone 1.5"
Easytech MN793 2GB Black
Upgraded to 3.5.37
File browsing & OGG
User avatar
mbc
 
Posts: 3
Joined: Sat Aug 26, 2006 9:03 pm
Location: Slovakia

Postby loverboy1981 » Fri Sep 01, 2006 8:28 pm

@mbc: Thank you.

@all: I just tested the video file with my original firmware and the player freezes after few seconds. With my new and modified firmware, the player plays the file.

The cutted stripes on the left and right side are also on my old firmware. So there are only advantages in the new firmware.
Last edited by loverboy1981 on Tue Sep 05, 2006 9:36 pm, edited 1 time in total.
1 dead + 1 modified I-Pod Nano Clone 1GB
Display: LY128128CS02-02
Board: MP-693C-SL MAIN v1.3 2005.12.14
Chip: ATJ2085H F6034AB C&C
Memory: SAMSUNG 619 | K9K8G08U0A PCB0 FUD8820

and one untouched 4GB with full filebrowsing and ogg support
loverboy1981
 
Posts: 24
Joined: Sat Aug 26, 2006 1:44 am

Updated firmware

Postby jy62 » Sun Sep 03, 2006 12:20 pm

Great work - this works like a dream with file browsing support and a great GUI. I enabled some items missing such as e-book and games in Waterlilly after uploading this FW and its fab.
Brilliant - I have loaded this on to both my Nano clone with no trouble.
SAMSUNG 628
K9WAG08UIA PCB0
MP-693CSL-MAIN V1.3 2006-12-14 :D :D :D

03/09
uploaded 2GB of music but the second half of the files are corrupted resulting in the player re-starting. Also when searching folders it takes nearly a minute for them to show and the same for the file browsing option. Could this be because the original firmware was based on a smaller capacity player rather than a 2GB one.

06/09
re-formatted using device manager in Windows Xp and everything is now fine - works like a dream and absolutely no problems with the mp3s I've loaded. Thankyou
Last edited by jy62 on Wed Sep 06, 2006 9:47 am, edited 1 time in total.
jy62
 
Posts: 13
Joined: Tue Aug 29, 2006 6:18 am
Location: UK

Next

Return to Firmware Features and Versions

Who is online

Users browsing this forum: No registered users and 2 guests



cron